$200 Steam Giftcard Raffle | Sponsored by TF1A3 ×
Jump to content
×
×
  • Create New...
  • 0

FivePD Key Binds Missing


Rickstar1
 Share

Reason for Locking
Solved

By TheCipher01, on 03/15/22 09:09 PM.

Question

I have purchased a FiveM server from Zap Hosting with FivePD working. I noticed last week that when I started FiveM it updated, then when attempting to play FivePD I noticed that the keys for the duty menu ( F11 ) , CAD ( B  )  and any key for FivePD did not work. After a while I checked key bindings and found that there was no longer a listing for the FivePD key binds in settings menu. Only FiveM key binds remained.  Zap Hosting will not help with any mods and it makes it hard to figure out where to start looking to solve the problem.  Where are those settings stored , SQL ?   How can I get those settings back?  I apologize if this question was asked. I did several searches and did not find anything like this in the forum.

 

 

 

Link to post
Share on other sites

5 answers to this question

Recommended Posts

  • 0
11 hours ago, Rickstar1 said:

I ran the live console and the one thing that stood out for FivePD was an error with the config.json .  Error says:  [ script:fivepd] [ FivePD ] An error has occured: [config.json] Invalid JSON format (Validate your config.json file). The error is around the 4. line     

Which I'm thinking possibly the mysql database because I am no longer able to log in to phpMyAdmin. Says access denied.  Maybe something changed in the config.json or more likely an error with the mysql database ?   I have a support ticket open with Zap Hosting regarding the denied access to phpMyAdmin and still waiting to hear about that. But still interested to know if that is where the FivePD key binds are stored.

 

 

So what that will do is actual cause FivePD not to load. If you don't mind post a screenshot of your config file with your database details blacked out

Alternatively you can use

https://jsonformatter.org/

  • Like 1
Link to post
Share on other sites

  • 0
1 minute ago, Rickstar1 said:

I have purchased a FiveM server from Zap Hosting with FivePD working. I noticed last week that when I started FiveM it updated, then when attempting to play FivePD I noticed that the keys for the duty menu ( F11 ) , CAD ( B  )  and any key for FivePD did not work. After a while I checked key bindings and found that there was no longer a listing for the FivePD key binds in settings menu. Only FiveM key binds remained.  Zap Hosting will not help with any mods and it makes it hard to figure out where to start looking to solve the problem.  Where are those settings stored , SQL ?   How can I get those settings back?  I apologize if this question was asked. I did several searches and did not find anything like this in the forum.

 

 

 

Check your live console and see if there are any errors when the server launches

Link to post
Share on other sites

  • 0
48 minutes ago, Grandpa Rex said:

Check your live console and see if there are any errors when the server launches

I ran the live console and the one thing that stood out for FivePD was an error with the config.json .  Error says:  [ script:fivepd] [ FivePD ] An error has occured: [config.json] Invalid JSON format (Validate your config.json file). The error is around the 4. line     

Which I'm thinking possibly the mysql database because I am no longer able to log in to phpMyAdmin. Says access denied.  Maybe something changed in the config.json or more likely an error with the mysql database ?   I have a support ticket open with Zap Hosting regarding the denied access to phpMyAdmin and still waiting to hear about that. But still interested to know if that is where the FivePD key binds are stored.

 

 

Link to post
Share on other sites

  • 0
1 hour ago, Grandpa Rex said:

So what that will do is actual cause FivePD not to load. If you don't mind post a screenshot of your config file with your database details blacked out

Alternatively you can use

https://jsonformatter.org/

Thank you for that link for jsonformatter . I never knew about that site. I ran my config through and it brought back error on line 3 which should have been {  but was name of database, I had changed it prior to this but had the parenthesis the wrong direction } once I saw that I had changed it but it didn't save my changes and I missed it so I made other changes thinking it was something else. Your assistance , the Zap hosting instructions for FivePD installing on this GTApolicemods and jsonformatter was very helpful.  Thanks Grandpa Rex for all your help and taking the time to sort this out and pointing me in the right direction. Server is running properly and keybinds are back. Problem solved.

config.json-image.JPG

config.json validate result.JPG

config.json zap hosting instructions.JPG

Link to post
Share on other sites

  • 0
  • Community Administrator

Content Lock Notice Visual

This content has been locked by the GPM Community Team. If you feel this was a mistake, please report this reply with a valid reason.

 

Cipher2.png

 

Community Administrator

Link to post
Share on other sites

Guest
This topic is now closed to further replies.
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.

Important Information

Thanks for visiting GPM. As a user of the GTAPoliceMods platform, we ask that you review the Terms of Use, Privacy Policy, and Guidelines. These principles allow us to continue fostering a great community. We have placed cookies on your device to help improve your experience. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.