Jump to content
×
×
  • Create New...
  • 0

Issues with garages


LRA1N
 Share

Reason for Locking
Solved.

By Lucky, on 08/28/21 01:46 AM.

Question

13 answers to this question

Recommended Posts

  • 1
  • Community Administrator
11 hours ago, LRA1N said:

also i think its worth noting that when i add the extras interger it breaks fivepd but when i remove it all is fine 

 

It's breaking because it's formatted incorrectly, you're missing a comma and several spots in the .json file that have been edited are missing commas or have improper formatting. I highly recommend using jsonformatter.org and copying and pasting in when you're making changes as it tells you if there are errors and how to fix them, additionally it can correct certain parts of the more tedious necessities for formatting as well.

 

Try this:

[
  {
    "isEnabled": true,
    "name": "Paleto Bay PD",
    "vehicles": [
      {
        "isEnabled": true,
        "location": {
          "x": -438.42,
          "y": 6028.29,
          "z": 31.34,
          "heading": 28.59
        },
        "vehicle": {
          "model": "charger2",
          "livery": 0
        }
      }
    ]
  },
  {
    "isEnabled": true,
    "name": "Mission Row PD",
    "vehicles": [
      {
        "isEnabled": true,
        "location": {
          "x": 446.28,
          "y": -986.32,
          "z": 25.24,
          "heading": 89.74
        },
        "vehicle": {
          "model": "13fpiuw",
          "livery": 0,
          "extras": [
            1,
            2,
            9,
            10,
            11,
            12
          ]
        }
      }
    ]
  }
]

 

 

 

Luckysig.png

 

GTAPoliceMods Community Administrator

Link to post
Share on other sites

  • 0

also when i try to add more vehicles everything stops working not able to open anything unless i remove the added vehicles, vehicles also do not respawn unless respawned via the admin subsection

Edited by LRA1N
additional info
Link to post
Share on other sites

  • 0
  • Community Administrator

Please share your garage file so we can assist you.

  • Like 1

 

Luckysig.png

 

GTAPoliceMods Community Administrator

Link to post
Share on other sites

  • 0

[
    {
        "isEnabled": true,
        "name": "Paleto Bay PD",
        "vehicles": [
            {
                "isEnabled": true,
                "location": {
                    "x": -438.42,
                    "y": 6028.29,
                    "z": 31.34,
                    "heading": 28.59,
                },
                "vehicle": {
                    "model": "charger2",
                    "livery": 0
                }
            }
        ]
    }
]    

thats all thats on there i tried to add the extras to determine the extras the vehicle has when spawned but didnt work also id like to add that i was able to get into the vehicle i guess sever just required a restart

Link to post
Share on other sites

  • 0

well the base one i just changed to reflect a new car but i cant add more or it breaks everything so id like to figure out how to add more than just one car without it breaking everything

 

also id like to know how to add in extras to the vehicle because that wasnt explained in the docs released 

Link to post
Share on other sites

  • 0
  • Community Administrator
4 hours ago, LRA1N said:

well the base one i just changed to reflect a new car but i cant add more or it breaks everything so id like to figure out how to add more than just one car without it breaking everything

 

also id like to know how to add in extras to the vehicle because that wasnt explained in the docs released 

For the first part, please provide an example of your garage.json in which you’ve added multiple vehicles and it broke, it’s likely a syntax error and you just need to get the formatting corrected.

 

As for extras, it is explained in the documents included with the download, specifically the configuration help doc. It lists it as an integer[].

 

”extras”: [1, 2, 3]

 

Luckysig.png

 

GTAPoliceMods Community Administrator

Link to post
Share on other sites

  • 0

Well i tried all different ways of trying to make it work but this is what i have sorry for the delayed response

 

i saw the thing on the docs but wasnt explained to well for someone who isnt good at that kinda stuff like me maybe make it more clearer with an example for people who are not experienced with that kinda stuff

 

[
    {
        "isEnabled": true,
        "name": "Paleto Bay PD",
        "vehicles": [
            {
                "isEnabled": true,
                "location": {
                    "x": -438.42,
                    "y": 6028.29,
                    "z": 31.34,
                    "heading": 28.59,
                },
                "vehicle": {
                    "model": "charger2",
                    "livery": 0
                }
            }
        ]
    }
    {
        "isEnabled": true,
        "name": "Mission Row PD",
        "vehicles": [
            {
                "isEnabled": true,
                "location": {
                    "x": 446.28,
                    "y": -986.32,
                    "z": 25.24,
                    "heading": 89.74,
                },
                "vehicle": {
                    "model": "13fpiuw",
                    "livery": 0
                    "extras": [1, 2, 9, 10, 11, 12]
                }
            }
        ]
    }        
]    

Link to post
Share on other sites

  • 0

hey that worked thanks so much i mean the cars dont respawn for me but thats not a huge deal i probably should use that website lol thanks again 🙂 

 

whilst your helping me if you have an idea of why its not respawning the cars that'd be nice if not no worries again not a big deal

Link to post
Share on other sites

  • 0
  • Community Administrator
39 minutes ago, LRA1N said:

hey that worked thanks so much i mean the cars dont respawn for me but thats not a huge deal i probably should use that website lol thanks again 🙂 

 

whilst your helping me if you have an idea of why its not respawning the cars that'd be nice if not no worries again not a big deal

No problem!

 

You’re on OneSync yes? If you are, it should work. Otherwise, it could be a known issue that I’m not personally aware of, to which it would be something to being worked on by the dev team.

 

Luckysig.png

 

GTAPoliceMods Community Administrator

Link to post
Share on other sites

  • 0

yea im on onesync ill just wait for the next update or look around see if others are experiecneing the same issue like i said not a big deal to me but thanks allot for the help 🙂

  • Like 1
Link to post
Share on other sites

  • 0
  • Community Administrator

content_locked.png

This content has been locked by the Community Team. If you feel this was a mistake, please report this reply with a valid reason.

 

Luckysig.png

 

GTAPoliceMods Community Administrator

Link to post
Share on other sites

Guest
This topic is now closed to further replies.
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.

Important Information

Thanks for visiting GPM. As a user of the GTAPoliceMods platform, we ask that you review the Terms of Use, Privacy Policy, and Guidelines. These principles allow us to continue fostering a great community. We have placed cookies on your device to help improve your experience. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.