Jump to content
×
×
  • Create New...
  • 0

Does anyone know why my ELS wont work?


Question

Let me elaborate, I have installed LuxArt controller, and MrDaGree Els system. It works for any other car, but I have this OPP car from lcpdfr.com, which I imported, put the vcf in, and streamed the car. The only problem I'm having is that it thinks its one stage, and that one stage is literally the brake lights cycling. When I press Q to switch stages, it just turns off. Anyone know how to fix?

Link to post
Share on other sites

19 answers to this question

Recommended Posts

  • 0

Might want to check the VCF. It could be set up incorrectly. 

  • Like 1

Sebo

Community Moderator

                                                                                                         

 

My personal Discord server: Click

My LSPDFR community Discord server: Click

Link to post
Share on other sites
  • 0
3 hours ago, Sebo said:

Might want to check the VCF. It could be set up incorrectly. 

I tried everything with it, I believe it's something else. VCF seems fine, I tried capital, lowercase, etc, it seems all good.

Link to post
Share on other sites
  • 0
8 hours ago, baconboidev said:

I tried everything with it, I believe it's something else. VCF seems fine, I tried capital, lowercase, etc, it seems all good.

If it's not a paid pack, could you link it? 
We could test if the VCF really is corrupted or not. 

Also; you may need to restart more than the resource, if you're using it on your server.

Link to post
Share on other sites
  • 0

Also make sure the resources.lua is set up properly. 
 

  • Like 1

Sebo

Community Moderator

                                                                                                         

 

My personal Discord server: Click

My LSPDFR community Discord server: Click

Link to post
Share on other sites
  • 0
5 hours ago, A Stranger said:

If it's not a paid pack, could you link it? 
We could test if the VCF really is corrupted or not. 

Also; you may need to restart more than the resource, if you're using it on your server.

https://www.lcpdfr.com/downloads/gta5mods/vehiclemodels/25892-els-lspd-legacy-pack/

The only other thing I mod is the texture, which I do with OpenIV, then put it in Stream.

Link to post
Share on other sites
  • 0
13 minutes ago, baconboidev said:

Where can I find that?


Depending on what ELS for FiveM you’re using, it’ll require a special line in the fxmanifest or resources.lua. 
you should check the readme of the ELS you’re using. 

Sebo

Community Moderator

                                                                                                         

 

My personal Discord server: Click

My LSPDFR community Discord server: Click

Link to post
Share on other sites
  • 0
1 hour ago, Sebo said:


Depending on what ELS for FiveM you’re using, it’ll require a special line in the fxmanifest or resources.lua. 
you should check the readme of the ELS you’re using. 

I checked the ReadMe, there is nothing there other than the installation guide which just says do the ensure ELS, and place it in resources.

Link to post
Share on other sites
  • 0
9 minutes ago, baconboidev said:

I checked the ReadMe, there is nothing there other than the installation guide which just says do the ensure ELS, and place it in resources.

 

There's more to it than those two steps.

https://github.com/MrDaGree/ELS-FiveM

  • Like 1

Sebo

Community Moderator

                                                                                                         

 

My personal Discord server: Click

My LSPDFR community Discord server: Click

Link to post
Share on other sites
  • 0

If they are replacements, the __resource.lua is usually empty, but ELS requires you to edit it differently.
1. You need  " is_els 'true' " at the bottom.

2. You need the .xml's in the "files" section of the __resource.lua.

 

For ELS: 

1. Have (whichever ELS you're using, we use ELSplus) in /resources.

2. Have it start in the server.cfg.

3. Restart the resource / your server to be sure.

Edited by A Stranger
I am an idiot.
Link to post
Share on other sites
  • 0
5 hours ago, A Stranger said:

If they are replacements, the __resource.lua is usually empty, but ELS requires you to edit it differently.
1. You need  " is_els 'true' " at the bottom.

2. You need the .xml's in the "files" section of the __resource.lua.

 

For ELS: 

1. Have (whichever ELS you're using, we use ELSplus) in /resources.

2. Have it start in the server.cfg.

3. Restart the resource / your server to be sure.

Where exactly is the ___resource.lua? That's the only thing I'm struggling with at this point.

Link to post
Share on other sites
  • 0

In your ELS resource folder. Could also be a fxmanifest.

Sebo

Community Moderator

                                                                                                         

 

My personal Discord server: Click

My LSPDFR community Discord server: Click

Link to post
Share on other sites
  • 0
21 minutes ago, Sebo said:

In your ELS resource folder. Could also be a fxmanifest.

Yeah, there's only a fxmanifest with this inside: I'll try to put that in there.

fx_version 'bodacious'
game 'gta5'

-- lua54 usage
lua54 'yes'

author 'MrDaGree'
description 'A resource which provides extensive controls for Emergency Lighting System-V created by Lt.Caine'

shared_script 'shared/*.lua'

client_script {
    'vcf.lua',
    'config.lua',
    'client/**/*.lua'
}

server_script {
    'vcf.lua',
    'config.lua',
    'server/**/*.lua'
}

 

Link to post
Share on other sites
  • 0
55 minutes ago, Sebo said:

In your ELS resource folder. Could also be a fxmanifest.

Alright, I tried what you said, still will not work, I am trying something else, but any more ideas/solutions?

Link to post
Share on other sites
  • 0

Maybe it's LuxArt thinking that it's a non ELS vehicle. I wouldn't know if you can blacklist it or something like that.

Sebo

Community Moderator

                                                                                                         

 

My personal Discord server: Click

My LSPDFR community Discord server: Click

Link to post
Share on other sites
  • 0
On 4/15/2021 at 12:04 PM, Sebo said:

Maybe it's LuxArt thinking that it's a non ELS vehicle. I wouldn't know if you can blacklist it or something like that.

Yeah I'm gonna look into that.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    No registered users viewing this page.

Important Information

Please view the site: Terms of Use, Privacy Policy, and Guidelines. // IMPORTANT: We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.