Jump to content
×
×
  • Create New...
  • 0

"Database connection could not be established"


BigBoomer07
 Share

Reason for Locking
Solved

By Conway, on 10/28/20 04:45 AM.

Question

Hello, I've been trying to get fivepd to run on my fivem server I use iceline for my host. I finally got it to load up, until it goes to connect to the database which then it says that my port may be wrong. I have checked multiple times and I have found the same port every time (3306) so I'm at a loss does anyone have any pointers to help this issue? thank you. p.s. I'm sending this question out at 1pm est I get off work at 8pm est so I will review and reply once I'm back at my desk. 

image.png

Link to post
Share on other sites

4 answers to this question

Recommended Posts

  • 1
56 minutes ago, BigBoomer07 said:

hi, i have made sure that the config.json file is correct with the ip and all, and as well i only have letters and numbers in my password for the database! i will contact their support team about the issues thank you

 

You may also want to try switching to sqlite if your using the 1.2 release.

  • Like 1
Link to post
Share on other sites

  • 1

Hello,

 

I have used Iceline services before & have been an employee with them previously so I may be able to help a little better than others. Here are a few possible solutions to your issue:

 

1) Ensure your database details are correct in the 'config.json' file. Ensure that the IP address and port numbers are correct.

2) Check that your database password doesn't contain any special characters (&, %, $ etc.) This is what has caused many problems for me in the past.

 

This error means that FivePD is simply unable to connect to the database. If these solutions dont work, I would recommend contacting their support team for further assistance.

Link to post
Share on other sites

  • 0
3 hours ago, Benzaboy said:

Hello,

 

I have used Iceline services before & have been an employee with them previously so I may be able to help a little better than others. Here are a few possible solutions to your issue:

 

1) Ensure your database details are correct in the 'config.json' file. Ensure that the IP address and port numbers are correct.

2) Check that your database password doesn't contain any special characters (&, %, $ etc.) This is what has caused many problems for me in the past.

 

This error means that FivePD is simply unable to connect to the database. If these solutions dont work, I would recommend contacting their support team for further assistance.

hi, i have made sure that the config.json file is correct with the ip and all, and as well i only have letters and numbers in my password for the database! i will contact their support team about the issues thank you

 

Link to post
Share on other sites

  • 0
  • Community Administrator

content_locked.png

This content has been locked by the Community Team. If you feel this was a mistake, please report this reply with a valid reason.

1181375915_ConwayGPMSign(2).png.222b6b96fc398f6107b76f0b800e9e59.png

 

Community Administrator and FivePD Support Guru

gpm_animated.gif

 

Link to post
Share on other sites

Guest
This topic is now closed to further replies.
 Share

  • Recently Browsing   0 members

    No registered users viewing this page.

Important Information

Please view the site: Terms of Use, Privacy Policy, and Guidelines. // IMPORTANT: We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.