Jump to content
×
×
  • Create New...
  • 0

Why do my liveries not work?!?


Go to solution Solved by Wolfrunner86,
Reason for Locking
Solved

By NorthCam18, on 07/25/20 04:59 PM.

Question

Hey guys, so I have made my custom liveries for my car, it has worked before on other cars where I add a 2nd, 3rd, 4th, and so on liveries that it randomly generates a different look each time, but this one car I have done so with does not do it, it spawns fine but always with the same skin over and over again, is there a limit on the number of liveries you can use in the game or certain vehicles? like I said its worked on all my other reskin projects until now. TIA 🙂

Link to post
Share on other sites

9 answers to this question

Recommended Posts

  • 1
  • Solution

replace use existing vehicle names, where as addons are custom names but you have to make sure to set up the carvariations & vehicles meta for the custom named vehicles

 

  • Like 1

"Prepare yourselves, the bells have tolled! Shelter your weak, your young and your old! Each of you shall pay the final sum! Cry for mercy; the reckoning has come!"

Twitch - - - Twitter

Link to post
Share on other sites
  • 0

Content_moved.png

This content has been moved to the correct section by the Community Team. Next time please post in the correct section.

If you feel this was a mistake, please report this reply with a valid reason.

TheCipher01

Community Team | Administrative Support

Link to post
Share on other sites
  • 0

Might want to make sure that the flag "FLAG_HAS_LIVERY" is in the vehicles.meta file. You can also use a trainer like simpletrainer, lambda menu or even vMenu (assuming it's FiveM) to change the car livery and see if it has the extra skin. Also make sure that it's named correctly to the other liverys ie if the first skin is charger_sign_1 make sure you keep it charger_sign_x

TheCipher01

Community Team | Administrative Support

Link to post
Share on other sites
  • 0
10 hours ago, TheCipher01 said:

Might want to make sure that the flag "FLAG_HAS_LIVERY" is in the vehicles.meta file. You can also use a trainer like simpletrainer, lambda menu or even vMenu (assuming it's FiveM) to change the car livery and see if it has the extra skin. Also make sure that it's named correctly to the other liverys ie if the first skin is charger_sign_1 make sure you keep it charger_sign_x

 

With vMenu I already tried and its got that (this car doesnt have livery) meaning something is wrong, it is named correctly, like I said I had done this many times before and it works fine. The only one thing it doesnt have is the vehicles.meta file which could be the problem, but why would that be if the other cars I did have none also but they work fine? It wouldnt possibly be the mipmaps would it? the car I changed the skin for was 10 mipmaps and I lowerd mine down to 1, just wondering?

EDIT: okay, its fixed! but why is this, I changed its name from "fbi2" to "police3" and now its working great! so obviously the "fbi2" has no liveries? cant that be overwritten with a veichiles.meta which I have also tried?!?

Edited by DarkXess
Link to post
Share on other sites
  • 0

alot of the default vehicles meta's cant be replaced on fivem which is why alot/most servers us addon vehicles instead of replace

 

"Prepare yourselves, the bells have tolled! Shelter your weak, your young and your old! Each of you shall pay the final sum! Cry for mercy; the reckoning has come!"

Twitch - - - Twitter

Link to post
Share on other sites
  • 0
40 minutes ago, Wolfrunner86 said:

alot of the default vehicles meta's cant be replaced on fivem which is why alot/most servers us addon vehicles instead of replace

 

I thought what I am doing IS addon cars?!?! what is the difference then with addon and replaced? as you see in the attached image isn't that the addon way?
data folder is for the meta files which I have added but still does not let me change the skin. Resource.lua is the following:
 

resource_manifest_version '44febabe-d386-4d18-afbe-5e627f4af937'

files {
    'data/carvariations.meta',
	'data/handling.meta',
	'data/vehicles.meta', --Vehicles.meta should ALWAYS be loaded last, no matter what
}

data_file 'VEHICLE_VARIATION_FILE' 'data/carvariations.meta'
data_file 'HANDLING_FILE' 'data/handling.meta'
data_file 'VEHICLE_METADATA_FILE' 'data/vehicles.meta'

I take it with addon vehicles they are just the plain model and made to work as said, no meta's etc included? so even I put the meta's they wont work?
 

Screenshot_2.png

Edited by DarkXess
Link to post
Share on other sites
  • 0
14 minutes ago, Wolfrunner86 said:

replace use existing vehicle names, where as addons are custom names but you have to make sure to set up the carvariations & vehicles meta for the custom named vehicles

 

Mind giving me an example or video guide if possible? I honestly dont get the difference what I am doing already mentioned further above, in this video for example it does what I have done already 😐

Edited by DarkXess
Link to post
Share on other sites
Guest
This topic is now closed to further replies.
  • Recently Browsing   0 members

    No registered users viewing this page.

Important Information

Please view the site: Terms of Use, Privacy Policy, and Guidelines. // IMPORTANT: We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.